package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:11|111)$(*SKIP)(*F)|.+`)
var str = `0
1
00
01
10
11
000
001
010
011
100
101
110
111
0000
0001
0010
0011
0100
0101
0110
0111
1000
1001
1010`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}