import re
regex = re.compile(r"^(?:11|111)$(*SKIP)(*F)|.+", flags=re.MULTILINE)
test_str = ("0\n"
"1\n"
"00\n"
"01\n"
"10\n"
"11\n"
"000\n"
"001\n"
"010\n"
"011\n"
"100\n"
"101\n"
"110\n"
"111\n"
"0000\n"
"0001\n"
"0010\n"
"0011\n"
"0100\n"
"0101\n"
"0110\n"
"0111\n"
"1000\n"
"1001\n"
"1010")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")