package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^#+&'"\\\s]+(?:\s[^#+&'"\\\s]+)*$`)
var str = `
---> invalid
---> invalid
a
---> invalid
a b
---> valid
a b
---> invalid`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}