$re = '/^[^#+&\'"\\\\\s]+(?:\s[^#+&\'"\\\\\s]+)*$/m';
$str = '
---> invalid
---> invalid
a
---> invalid
a b
---> valid
a b
---> invalid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);