re = /^[^#+&'"\\\s]+(?:\s[^#+&'"\\\s]+)*$/m
str = '
---> invalid
---> invalid
a
---> invalid
a b
---> valid
a b
---> invalid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end