$re = '/(^\w{0,30}){1}(\s?(\w{0,30})){1,4}/m';
$str = 'fwe foiwje ofi wjeof wwerwer qweqwe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);