re = /(^\w{0,30}){1}(\s?(\w{0,30})){1,4}/m
str = 'fwe foiwje ofi wjeof wwerwer qweqwe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end