import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\/\\-\\.a-zA-Z0-9])([a-zA-Z0-9]+[\\/\\-\\.][a-zA-Z0-9]+)(?![\\/\\-\\.a-zA-Z0-9])";
final String string = "Foo [1234/101] bar 645/622/NBHJgytgf265016\n\n"
+ " Foo [1234-101] bar 456B/Bhghy90 baz 5/3/2016";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}