$re = '/(?<![\/\-\.a-zA-Z0-9])([a-zA-Z0-9]+[\/\-\.][a-zA-Z0-9]+)(?![\/\-\.a-zA-Z0-9])/';
$str = 'Foo [1234/101] bar 645/622/NBHJgytgf265016
Foo [1234-101] bar 456B/Bhghy90 baz 5/3/2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);