const regex = /(?<![\/\-\.a-zA-Z0-9])([a-zA-Z0-9]+[\/\-\.][a-zA-Z0-9]+)(?![\/\-\.a-zA-Z0-9])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\\/\\-\\.a-zA-Z0-9])([a-zA-Z0-9]+[\\\/\\-\\.][a-zA-Z0-9]+)(?![\\\/\\-\\.a-zA-Z0-9])', 'g')
const str = `Foo [1234/101] bar 645/622/NBHJgytgf265016
Foo [1234-101] bar 456B/Bhghy90 baz 5/3/2016`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}