package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?'Username'[-\w\d\.]+?)(?:\s+at\s+|\s+\[at\]\s+|\s*@\s*|\s*(?:[\[\]@]){3}\s*)(?'Domain'[-\w\d\.]*?)\s*(?:dot|\.|(?:[\[\]dot\.]){3,5})\s*(?'TLD'\w+)$`)
var str = `some.email at gmail dot com
asdf-FDSA at ghjkl . net
thomas at yahoo .de
josh@awesomecompanyname dot com
mona.lisa [@] domain [dot] com
stephen.spielberg [@] domain [.] com
lol.dzdz [at] fe dot com
He is not at his best. Lorem Ipsum.
Hit "Perform a substitution" to see some magic happen.`
var substitution = "\1@\2.\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}