using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^STRBI_(\d{10})_(\d{8})_(STK|SLS)_(.+)\.(\w{3,})$";
string input = @"STRBI_0000010006_20171030_STK_Informe de Stock_20171029.csv
STRBI_0000010007_20171030_STK_Informe de Stock_20171029.csv
STRBI_0000010067_20171030_STK_Informe de Stock_20171009.csv
STRBI_0000010087_20171030_SLS_Informe de Ventas Diarias_20171029.csv
STRBI_0000010087_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv
STRBI_0000010087_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv
STRBI_0000010092_20171030_SLS_Informe de Ventas Diarias_20171029.csv
STRBI_0000010092_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv
STRBI_0000010092_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}