import re
regex = re.compile(r"^STRBI_(\d{10})_(\d{8})_(STK|SLS)_(.+)\.(\w{3,})$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("STRBI_0000010006_20171030_STK_Informe de Stock_20171029.csv\n"
"STRBI_0000010007_20171030_STK_Informe de Stock_20171029.csv\n"
"STRBI_0000010067_20171030_STK_Informe de Stock_20171009.csv\n"
"STRBI_0000010087_20171030_SLS_Informe de Ventas Diarias_20171029.csv\n"
"STRBI_0000010087_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv\n"
"STRBI_0000010087_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv\n"
"STRBI_0000010092_20171030_SLS_Informe de Ventas Diarias_20171029.csv\n"
"STRBI_0000010092_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv\n"
"STRBI_0000010092_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")