package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s\([^()]{0,100}\)\s`)
var str = `this is a text ( with parts in brackets ) . This is another string ( with a very long string between brackets that should not be removed because it is too long being over 100 characters )`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}