re = /\s\([^()]{0,100}\)\s/m
str = 'this is a text ( with parts in brackets ) . This is another string ( with a very long string between brackets that should not be removed because it is too long being over 100 characters )'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result