$re = '/\s\([^()]{0,100}\)\s/m';
$str = 'this is a text ( with parts in brackets ) . This is another string ( with a very long string between brackets that should not be removed because it is too long being over 100 characters )';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;