use strict;
my $str = '5"
5\' 11"
78-5/8"
5" x 36"
5" x 1.51" x 36"
5.0" x 1.51" x 36.1"
1.51\' x 36\' 3"
1.51\' x 36\' 3.0625"
5\' x 1.51\' x 36\' 3"
5" x 1.51"
5\' x 11\'
33-5/8" x 1.510" x 78-5/8"
';
my $regex = qr/(?:(\d*)['"]|(\d*\.\d*)['"]|(\d*(?>') \d*\.?\d*)["]|(\d*-\d\/\d)")/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}