import Foundation
let pattern = #"(?:(\d*)['"]|(\d*\.\d*)['"]|(\d*(?>') \d*\.?\d*)["]|(\d*-\d\/\d)")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
5"
5' 11"
78-5/8"
5" x 36"
5" x 1.51" x 36"
5.0" x 1.51" x 36.1"
1.51' x 36' 3"
1.51' x 36' 3.0625"
5' x 1.51' x 36' 3"
5" x 1.51"
5' x 11'
33-5/8" x 1.510" x 78-5/8"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)