$re = '/(?:(\d*)[\'"]|(\d*\.\d*)[\'"]|(\d*(?>\') \d*\.?\d*)["]|(\d*-\d\/\d)")/m';
$str = '5"
5\' 11"
78-5/8"
5" x 36"
5" x 1.51" x 36"
5.0" x 1.51" x 36.1"
1.51\' x 36\' 3"
1.51\' x 36\' 3.0625"
5\' x 1.51\' x 36\' 3"
5" x 1.51"
5\' x 11\'
33-5/8" x 1.510" x 78-5/8"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);