import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z0-9Ά-ωΑ-ώ\\s]*";
final String string = "Η σελίδα αυτή είναι απαÏαίτητη για να δημοσιεÏσετε Îνα σχόλιο. Και δεν Îχει οÏτε τώÏα ή Ï€Ïόκειται να θÎλετε να Ïυθμίσετε το παιχνίδι μου πολλά. Στην παÏοχή συμβουλών στους ασθενείς σε όλο τον κόσμο, οι οποίοι είναι διαθÎσιμοι, αλλά Ï€Ïιν ξεκινήσετε\n\n"
+ "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nunc vel mi ac neque fringilla egestas ut sit amet felis. In malesuada lacinia ligula, quis tincidunt ante sollicitudin sed.\n\n"
+ "12351432123213";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}