import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Main:\\s*\\w*\\(\\s*\\)\\s*\\{ <--[^\\}]*(?:\\}(?! <--)[^\\}]*)*\\} <--$";
final String string = "Main: Subroutine( )\n"
+ "{ <--\n"
+ " Include(foo = bar )\n"
+ " Call(foo = bar )\n"
+ " Repeat(foo = ibar )\n"
+ " {\n"
+ " Message(\"Message = bar number {ibar}\" foo )\n"
+ " Something( )\n"
+ " Message(\"Message = foo {bar}\" )\n"
+ " }\n"
+ " Message(\"Message = again {iterations}\" )\n"
+ " For(start = foo , end = bar )\n"
+ " {\n"
+ " Comment( )\n"
+ " }\n"
+ " While(foo )\n"
+ " {\n"
+ " Comment( )\n"
+ " }\n"
+ " Comment( )\n"
+ "} <--";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}