import re
regex = re.compile(r"^Main:\s*\w*\(\s*\)\s*\{ <--[^}]*(?:\}(?! <--)[^}]*)*\} <--$", flags=re.MULTILINE)
test_str = ("Main: Subroutine( )\n"
"{ <--\n"
" Include(foo = bar )\n"
" Call(foo = bar )\n"
" Repeat(foo = ibar )\n"
" {\n"
" Message(\"Message = bar number {ibar}\" foo )\n"
" Something( )\n"
" Message(\"Message = foo {bar}\" )\n"
" }\n"
" Message(\"Message = again {iterations}\" )\n"
" For(start = foo , end = bar )\n"
" {\n"
" Comment( )\n"
" }\n"
" While(foo )\n"
" {\n"
" Comment( )\n"
" }\n"
" Comment( )\n"
"} <--")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")