use strict;
my $str = 'Lorem \'Ipsum\' is simply: dummy \'http://www.exmplelink1.com/blah/blah/file 1 b.txt\' text of the printing \'http://www.exmplelink1.com/blah/blah/file 1 c.txt\' and typesetting industry. Lorem Ipsum \'http://www.exmplelink2.com/blah/file.txt\' has been, the \'industry\'s standard\'';
my $regex = qr/'http:\/\/www\.exmplelink1.*?'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}