$re = '/\'http:\/\/www\.exmplelink1.*?\'/m';
$str = 'Lorem \'Ipsum\' is simply: dummy \'http://www.exmplelink1.com/blah/blah/file 1 b.txt\' text of the printing \'http://www.exmplelink1.com/blah/blah/file 1 c.txt\' and typesetting industry. Lorem Ipsum \'http://www.exmplelink2.com/blah/file.txt\' has been, the \'industry\'s standard\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);