re = /'http:\/\/www\.exmplelink1.*?'/m
str = 'Lorem \'Ipsum\' is simply: dummy \'http://www.exmplelink1.com/blah/blah/file 1 b.txt\' text of the printing \'http://www.exmplelink1.com/blah/blah/file 1 c.txt\' and typesetting industry. Lorem Ipsum \'http://www.exmplelink2.com/blah/file.txt\' has been, the \'industry\'s standard\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end