#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)structure|(constant\s+?maturity\s+?|CMS|CMT)|inverse\s+?floater|snow\w+|steepener|flattener|(digital|callable|accrual|CRANS)|(variance|volatility)|quanto|trigger"
Local $sString = "• Anything with “Structured Note”" & @CRLF & _
"• Anything with “Constant Maturity swap” or “CMS” (i.e., “CMS” or “CMS option”)" & @CRLF & _
"• Anything with “Constant Maturity Treasuries” or “CMT” (i.e., “CMT swaps or CMT swaptions”)" & @CRLF & _
"• Anything with “Inverse floater” inverse floater" & @CRLF & _
"• Anything with “Snowball”" & @CRLF & _
"• Anything with “Steepener”" & @CRLF & _
"• Anything with “Flattener”" & @CRLF & _
"• Anything with “Digital and Callable Range Accrual Notes” (“CRANS”)" & @CRLF & _
"• Anything with “Variance” or “Volatility” in connection with “swap”" & @CRLF & _
"• Anything describing a “Quanto” swap or swaption" & @CRLF & _
"• Anything describing a “Trigger” swap or swaption" & @CRLF & _
" " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")