import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "structure|(constant\\s+?maturity\\s+?|CMS|CMT)|inverse\\s+?floater|snow\\w+|steepener|flattener|(digital|callable|accrual|CRANS)|(variance|volatility)|quanto|trigger";
final String string = "• Anything with “Structured Note”\n"
+ "• Anything with “Constant Maturity swap” or “CMS” (i.e., “CMS” or “CMS option”)\n"
+ "• Anything with “Constant Maturity Treasuries” or “CMT” (i.e., “CMT swaps or CMT swaptions”)\n"
+ "• Anything with “Inverse floater” inverse floater\n"
+ "• Anything with “Snowball”\n"
+ "• Anything with “Steepener”\n"
+ "• Anything with “Flattener”\n"
+ "• Anything with “Digital and Callable Range Accrual Notes” (“CRANS”)\n"
+ "• Anything with “Variance” or “Volatility” in connection with “swap”\n"
+ "• Anything describing a “Quanto” swap or swaption\n"
+ "• Anything describing a “Trigger” swap or swaption\n"
+ " \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}