import re
regex = re.compile(r"structure|(constant\s+?maturity\s+?|CMS|CMT)|inverse\s+?floater|snow\w+|steepener|flattener|(digital|callable|accrual|CRANS)|(variance|volatility)|quanto|trigger", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("• Anything with “Structured Note”\n"
"• Anything with “Constant Maturity swap” or “CMS” (i.e., “CMS” or “CMS option”)\n"
"• Anything with “Constant Maturity Treasuries” or “CMT” (i.e., “CMT swaps or CMT swaptions”)\n"
"• Anything with “Inverse floater” inverse floater\n"
"• Anything with “Snowball”\n"
"• Anything with “Steepener”\n"
"• Anything with “Flattener”\n"
"• Anything with “Digital and Callable Range Accrual Notes” (“CRANS”)\n"
"• Anything with “Variance” or “Volatility” in connection with “swap”\n"
"• Anything describing a “Quanto” swap or swaption\n"
"• Anything describing a “Trigger” swap or swaption\n"
" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")