package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:([AE][0-9]{7})|(IN:(?1)Q))$`)
var str = `IN:E0123463Q`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}