const regex = /^(?:([AE][0-9]{7})|(IN:(?1)Q))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:([AE][0-9]{7})|(IN:(?1)Q))$', '')
const str = `IN:E0123463Q`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}