$re = '/^(?:([AE][0-9]{7})|(IN:(?1)Q))$/';
$str = 'IN:E0123463Q';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);