package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Data Source=([^;]*);`)
var str = `Provider=SQLOLEDB;Data Source=197.167.12.63;Initial Catalog=TEST;User Id=user;Password=123;Persist Security Info=True`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}