re = /Data Source=([^;]*);/m
str = 'Provider=SQLOLEDB;Data Source=197.167.12.63;Initial Catalog=TEST;User Id=user;Password=123;Persist Security Info=True'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end