$re = '/Data Source=([^;]*);/m';
$str = 'Provider=SQLOLEDB;Data Source=197.167.12.63;Initial Catalog=TEST;User Id=user;Password=123;Persist Security Info=True';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);