using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^0-9](?=[0-9])";
string substitution = @"$& ";
string input = @"E2356
E123-F456";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}