import Foundation
let pattern = #"[^0-9](?=[0-9])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
E2356
E123-F456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$& "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)