$re = '/[^0-9](?=[0-9])/';
$str = 'E2356
E123-F456';
$subst = "$& ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;