import Foundation
let pattern = #"([^"'(])*?3.png([^"')]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<img src="images/3.png" alt="" width="19" style="font-family:Arial,Helvetica,sans-serif;font-size:13px;line-height:13px;display:block;border:none" class="t_w100p m_w100p" />
<img src="3.png" alt="" width="19" style="font-family:Arial,Helvetica,sans-serif;font-size:13px;line-height:13px;display:block;border:none" class="t_w100p m_w100p" />
<img src="13.png" alt="" width="19" style="font-family:Arial,Helvetica,sans-serif;font-size:13px;line-height:13px;display:block;border:none" class="t_w100p m_w100p" />
<img src="images/13.png" alt="" width="19" style="font-family:Arial,Helvetica,sans-serif;font-size:13px;line-height:13px;display:block;border:none" class="t_w100p m_w100p" />
<style> ul { background: url('images/3.png') }</style>
<style> ul { background: url('3.png') }</style>
<style> ul { background: url('images/13.png') }</style>
<style> ul { background: url('13.png') }</style>
<style> ul { background: url(images/13.png) }</style>
<style> ul { background: url(13.png) }</style>
<style> ul { background: url(images/3.png) }</style>
<style> ul { background: url(3.png) }</style>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://stackoverflow.com"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)