package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<td(.+|)(class="myClass")(.+|)>(.+)<\/td>`)
var str = `<td>I Dont want this</td>
<td class="myClass">I want this</td>
<td class="myClass" id="myID">I want this</td>
<td style="border-top-width: 0px; class="myClass">I want this</td>
<td class="niggaWhat" yoh how are you>as long as</td>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}