// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<td(.+|)(class="myClass")(.+|)>(.+)<\/td>"#).unwrap();
let string = "<td>I Dont want this</td>
<td class=\"myClass\">I want this</td>
<td class=\"myClass\" id=\"myID\">I want this</td>
<td style=\"border-top-width: 0px; class=\"myClass\">I want this</td>
<td class=\"niggaWhat\" yoh how are you>as long as</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}