#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(?\{@\w+\s(\w+)\|\d+-\d+\|\w+\|?\w+?\}\)?"
Local $sString = "{@spell wall of force} <- \(?\{@\w+\s+(\w+\s+\w+\s+\w+)\}\)?" & @CRLF & _
"" & @CRLF & _
"({@damage 2d8} <- \(?\{@\w+\s+(\d+d\d+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@condition unconscious} <- \(?\{@\w+\s+(\w+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@creature Bestial Spirit|TCE} <- \(?\{@\w+\s+(\w+\s\w+)\|\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@scaledamage 1d8|3,5,7,9|1d8} <- \(?\{@\w+\s(\w+)\|.......\|\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@dice 1d10 × 1d10} <- \(?\{@\w+\s(\w+\s×\s\w+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@scaledamage 2d8|1-9|1d8} <- \(?\{@\w+\s(\w+)\|\d+-\d+\|\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@dice 1d4 + 1} <- \(?\{@\w+\s(\w+\s\+\s\d+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@dice 1d4 - 1} <- \(?\{@\w+\s(\w+\s-\s\d+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@dice 1d20 - 3|4} <- \(?\{@\w+\s+(\w+\s+-\s+\w+)\|\d+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@dice 1d20 + 4|18} <- \(?\{@\w+\s+(\w+\s\+\s\d+)\|\d+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@hit +6} <- \(?\{@\w+\s+(\+\d+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@creature animated object (tiny)|phb|Tiny} <- \(?\{@\w+\s+(\w+\s\w+\s\(\w+\))\|\w+\|\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@spell magic missile} <- \(?\{@\w+\s+(\w+\s+\w+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@chance 25|25 percent} <- \(?\{@\w+\s+\d+\|(\w+\s+\w+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@filter beast of challenge rating 2 or lower|bestiary|challenge rating=[&0;&2]|type=beast|miscellaneous=!swarm} <- \(?\{@\w+\s+(\w+\s+\w+\s+\w+\s+\w+\s+\d+\s+\w+\s+\w+)\|\w+\|\w+\s+\w+=\[&\d+;&\d+\]\|\w+=\w+\|\w+=!\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@filter beasts of challenge rating 1/2 or lower|bestiary|challenge rating=[&0;&1/2]|type=beast|miscellaneous=!swarm} <- \(?\{@\w+\s+(\w+\s+\w+\s+\w+\s+\w+\s+\d+\/\d+\s+\w+\s+\w+)\|\w+\|\w+\s\w+=\[&\d+;&\d+\/\d+\]\|\w+=\w+\|\w+=!\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@filter fey creatures of challenge rating 1/4 or lower|bestiary|challenge rating=[&0;&1/4]|type=fey|miscellaneous=!swarm} <- \(?\{@\w+\s+(\w+\s+\w+\s+\w+\s+\w+\s+\w+\s+\d+\/\d+\s+\w+\s+\w+)\|\w+\|\w+\s+\w+=\[&\d+;&\d+\/\d+\]\|\w+=\w+\|\w+=!\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@filter fey creatures of challenge rating 1 or lower|bestiary|challenge rating=[&0;&1]|type=fey|miscellaneous=!swarm} <- \(?\{@\w+\s+(\w+\s+\w+\s+\w+\s+\w+\s+\w+\s+\d+\s+\w+\s+\w+)\|\w+\|\w+\s+\w+=\[&\d+;&\d+\]\|\w+=\w+\|\w+=!\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@item arrow|phb|arrows} <- \(?\{@\w+\s+(\w+)\|\w+\|\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@item crossbow bolt|phb|crossbow bolts} <- \(?\{@\w+\s+\w+\s+\w+\|\w+\|\w+\s+\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@creature ghoul||ghouls} <-\(?\{@\w+\s+\w+\|\|(\w+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@filter fey|bestiary|type=fey|miscellaneous=!swarm} <- \(?\{@\w+\s+(\w+)\|\w+\|\w+=\w+\|\w+=!\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@filter any beast|bestiary|type=beast|miscellaneous=!swarm} <- \(?\{@\w+\s+(\w+\s+\w+)\|\w+\|\w+=\w+\|\w+=!\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@race dwarf (hill)||Dwarf, hill} <- \(?\{@\w+\s+\w+\s+\(\w+\)\|\|(\w+,\s+\w+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@race Half-elf} <- \(?\{@\w+\s+(\w+-?\w+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@filter divination spells|spells|school=D} <- \(?\{@\w+\s+(\w+\s+\w+)\|\w+\|\w+=\w+\}\)?" & @CRLF & _
"" & @CRLF & _
"{@scaledamage 4d8;2d8|5-9|1d8} <- \(?\{@\w+\s+\w+;\w+\|\d+-\d+\|(\w+)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@creature saber-toothed tiger} <- \(?\{@\w+\s+(\w+?-?\w+?\s+?\w+?)\}\)?" & @CRLF & _
"" & @CRLF & _
"{@filter challenge rating 6 or lower|bestiary|challenge rating=[&0;&6]|tag=devil|miscellaneous=!swarm} <- \(?\{@filter (\w+\s+\w+\s+\d+\s+\w+\s+\w+)\|\w+\|\w+\s+\w+=\[&\d+;&\d+\]\|\w+=\w+\|\w+=!\w+\}\)?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")