use strict;
my $str = '{@spell wall of force} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+\\s+\\w+)\\}\\)?
({@damage 2d8} <- \\(?\\{@\\w+\\s+(\\d+d\\d+)\\}\\)?
{@condition unconscious} <- \\(?\\{@\\w+\\s+(\\w+)\\}\\)?
{@creature Bestial Spirit|TCE} <- \\(?\\{@\\w+\\s+(\\w+\\s\\w+)\\|\\w+\\}\\)?
{@scaledamage 1d8|3,5,7,9|1d8} <- \\(?\\{@\\w+\\s(\\w+)\\|.......\\|\\w+\\}\\)?
{@dice 1d10 × 1d10} <- \\(?\\{@\\w+\\s(\\w+\\s×\\s\\w+)\\}\\)?
{@scaledamage 2d8|1-9|1d8} <- \\(?\\{@\\w+\\s(\\w+)\\|\\d+-\\d+\\|\\w+\\}\\)?
{@dice 1d4 + 1} <- \\(?\\{@\\w+\\s(\\w+\\s\\+\\s\\d+)\\}\\)?
{@dice 1d4 - 1} <- \\(?\\{@\\w+\\s(\\w+\\s-\\s\\d+)\\}\\)?
{@dice 1d20 - 3|4} <- \\(?\\{@\\w+\\s+(\\w+\\s+-\\s+\\w+)\\|\\d+\\}\\)?
{@dice 1d20 + 4|18} <- \\(?\\{@\\w+\\s+(\\w+\\s\\+\\s\\d+)\\|\\d+\\}\\)?
{@hit +6} <- \\(?\\{@\\w+\\s+(\\+\\d+)\\}\\)?
{@creature animated object (tiny)|phb|Tiny} <- \\(?\\{@\\w+\\s+(\\w+\\s\\w+\\s\\(\\w+\\))\\|\\w+\\|\\w+\\}\\)?
{@spell magic missile} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+)\\}\\)?
{@chance 25|25 percent} <- \\(?\\{@\\w+\\s+\\d+\\|(\\w+\\s+\\w+)\\}\\)?
{@filter beast of challenge rating 2 or lower|bestiary|challenge rating=[&0;&2]|type=beast|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\d+\\s+\\w+\\s+\\w+)\\|\\w+\\|\\w+\\s+\\w+=\\[&\\d+;&\\d+\\]\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?
{@filter beasts of challenge rating 1/2 or lower|bestiary|challenge rating=[&0;&1/2]|type=beast|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\d+\\/\\d+\\s+\\w+\\s+\\w+)\\|\\w+\\|\\w+\\s\\w+=\\[&\\d+;&\\d+\\/\\d+\\]\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?
{@filter fey creatures of challenge rating 1/4 or lower|bestiary|challenge rating=[&0;&1/4]|type=fey|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\d+\\/\\d+\\s+\\w+\\s+\\w+)\\|\\w+\\|\\w+\\s+\\w+=\\[&\\d+;&\\d+\\/\\d+\\]\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?
{@filter fey creatures of challenge rating 1 or lower|bestiary|challenge rating=[&0;&1]|type=fey|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\d+\\s+\\w+\\s+\\w+)\\|\\w+\\|\\w+\\s+\\w+=\\[&\\d+;&\\d+\\]\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?
{@item arrow|phb|arrows} <- \\(?\\{@\\w+\\s+(\\w+)\\|\\w+\\|\\w+\\}\\)?
{@item crossbow bolt|phb|crossbow bolts} <- \\(?\\{@\\w+\\s+\\w+\\s+\\w+\\|\\w+\\|\\w+\\s+\\w+\\}\\)?
{@creature ghoul||ghouls} <-\\(?\\{@\\w+\\s+\\w+\\|\\|(\\w+)\\}\\)?
{@filter fey|bestiary|type=fey|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+)\\|\\w+\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?
{@filter any beast|bestiary|type=beast|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+)\\|\\w+\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?
{@race dwarf (hill)||Dwarf, hill} <- \\(?\\{@\\w+\\s+\\w+\\s+\\(\\w+\\)\\|\\|(\\w+,\\s+\\w+)\\}\\)?
{@race Half-elf} <- \\(?\\{@\\w+\\s+(\\w+-?\\w+)\\}\\)?
{@filter divination spells|spells|school=D} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+)\\|\\w+\\|\\w+=\\w+\\}\\)?
{@scaledamage 4d8;2d8|5-9|1d8} <- \\(?\\{@\\w+\\s+\\w+;\\w+\\|\\d+-\\d+\\|(\\w+)\\}\\)?
{@creature saber-toothed tiger} <- \\(?\\{@\\w+\\s+(\\w+?-?\\w+?\\s+?\\w+?)\\}\\)?
{@filter challenge rating 6 or lower|bestiary|challenge rating=[&0;&6]|tag=devil|miscellaneous=!swarm} <- \\(?\\{@filter (\\w+\\s+\\w+\\s+\\d+\\s+\\w+\\s+\\w+)\\|\\w+\\|\\w+\\s+\\w+=\\[&\\d+;&\\d+\\]\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?';
my $regex = qr/\(?\{@\w+\s(\w+)\|\d+-\d+\|\w+\|?\w+?\}\)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}