import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?\\{@\\w+\\s(\\w+)\\|\\d+-\\d+\\|\\w+\\|?\\w+?\\}\\)?";
final String string = "{@spell wall of force} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+\\s+\\w+)\\}\\)?\n\n"
+ "({@damage 2d8} <- \\(?\\{@\\w+\\s+(\\d+d\\d+)\\}\\)?\n\n"
+ "{@condition unconscious} <- \\(?\\{@\\w+\\s+(\\w+)\\}\\)?\n\n"
+ "{@creature Bestial Spirit|TCE} <- \\(?\\{@\\w+\\s+(\\w+\\s\\w+)\\|\\w+\\}\\)?\n\n"
+ "{@scaledamage 1d8|3,5,7,9|1d8} <- \\(?\\{@\\w+\\s(\\w+)\\|.......\\|\\w+\\}\\)?\n\n"
+ "{@dice 1d10 × 1d10} <- \\(?\\{@\\w+\\s(\\w+\\s×\\s\\w+)\\}\\)?\n\n"
+ "{@scaledamage 2d8|1-9|1d8} <- \\(?\\{@\\w+\\s(\\w+)\\|\\d+-\\d+\\|\\w+\\}\\)?\n\n"
+ "{@dice 1d4 + 1} <- \\(?\\{@\\w+\\s(\\w+\\s\\+\\s\\d+)\\}\\)?\n\n"
+ "{@dice 1d4 - 1} <- \\(?\\{@\\w+\\s(\\w+\\s-\\s\\d+)\\}\\)?\n\n"
+ "{@dice 1d20 - 3|4} <- \\(?\\{@\\w+\\s+(\\w+\\s+-\\s+\\w+)\\|\\d+\\}\\)?\n\n"
+ "{@dice 1d20 + 4|18} <- \\(?\\{@\\w+\\s+(\\w+\\s\\+\\s\\d+)\\|\\d+\\}\\)?\n\n"
+ "{@hit +6} <- \\(?\\{@\\w+\\s+(\\+\\d+)\\}\\)?\n\n"
+ "{@creature animated object (tiny)|phb|Tiny} <- \\(?\\{@\\w+\\s+(\\w+\\s\\w+\\s\\(\\w+\\))\\|\\w+\\|\\w+\\}\\)?\n\n"
+ "{@spell magic missile} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+)\\}\\)?\n\n"
+ "{@chance 25|25 percent} <- \\(?\\{@\\w+\\s+\\d+\\|(\\w+\\s+\\w+)\\}\\)?\n\n"
+ "{@filter beast of challenge rating 2 or lower|bestiary|challenge rating=[&0;&2]|type=beast|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\d+\\s+\\w+\\s+\\w+)\\|\\w+\\|\\w+\\s+\\w+=\\[&\\d+;&\\d+\\]\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?\n\n"
+ "{@filter beasts of challenge rating 1/2 or lower|bestiary|challenge rating=[&0;&1/2]|type=beast|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\d+\\/\\d+\\s+\\w+\\s+\\w+)\\|\\w+\\|\\w+\\s\\w+=\\[&\\d+;&\\d+\\/\\d+\\]\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?\n\n"
+ "{@filter fey creatures of challenge rating 1/4 or lower|bestiary|challenge rating=[&0;&1/4]|type=fey|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\d+\\/\\d+\\s+\\w+\\s+\\w+)\\|\\w+\\|\\w+\\s+\\w+=\\[&\\d+;&\\d+\\/\\d+\\]\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?\n\n"
+ "{@filter fey creatures of challenge rating 1 or lower|bestiary|challenge rating=[&0;&1]|type=fey|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\d+\\s+\\w+\\s+\\w+)\\|\\w+\\|\\w+\\s+\\w+=\\[&\\d+;&\\d+\\]\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?\n\n"
+ "{@item arrow|phb|arrows} <- \\(?\\{@\\w+\\s+(\\w+)\\|\\w+\\|\\w+\\}\\)?\n\n"
+ "{@item crossbow bolt|phb|crossbow bolts} <- \\(?\\{@\\w+\\s+\\w+\\s+\\w+\\|\\w+\\|\\w+\\s+\\w+\\}\\)?\n\n"
+ "{@creature ghoul||ghouls} <-\\(?\\{@\\w+\\s+\\w+\\|\\|(\\w+)\\}\\)?\n\n"
+ "{@filter fey|bestiary|type=fey|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+)\\|\\w+\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?\n\n"
+ "{@filter any beast|bestiary|type=beast|miscellaneous=!swarm} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+)\\|\\w+\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?\n\n"
+ "{@race dwarf (hill)||Dwarf, hill} <- \\(?\\{@\\w+\\s+\\w+\\s+\\(\\w+\\)\\|\\|(\\w+,\\s+\\w+)\\}\\)?\n\n"
+ "{@race Half-elf} <- \\(?\\{@\\w+\\s+(\\w+-?\\w+)\\}\\)?\n\n"
+ "{@filter divination spells|spells|school=D} <- \\(?\\{@\\w+\\s+(\\w+\\s+\\w+)\\|\\w+\\|\\w+=\\w+\\}\\)?\n\n"
+ "{@scaledamage 4d8;2d8|5-9|1d8} <- \\(?\\{@\\w+\\s+\\w+;\\w+\\|\\d+-\\d+\\|(\\w+)\\}\\)?\n\n"
+ "{@creature saber-toothed tiger} <- \\(?\\{@\\w+\\s+(\\w+?-?\\w+?\\s+?\\w+?)\\}\\)?\n\n"
+ "{@filter challenge rating 6 or lower|bestiary|challenge rating=[&0;&6]|tag=devil|miscellaneous=!swarm} <- \\(?\\{@filter (\\w+\\s+\\w+\\s+\\d+\\s+\\w+\\s+\\w+)\\|\\w+\\|\\w+\\s+\\w+=\\[&\\d+;&\\d+\\]\\|\\w+=\\w+\\|\\w+=!\\w+\\}\\)?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}