$re = '/(?:\s|^)@[a-z]+(?!\S)/mi';
$str = '@username
@@username
hey @username
@usern@name
hey@username';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);