re = /(?:\s|^)@[a-z]+(?!\S)/mi
str = '@username
@@username
hey @username
@usern@name
hey@username'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end