import re
regex = re.compile(r"(?:\s|^)@[a-z]+(?!\S)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("@username\n\n"
"@@username\n\n"
"hey @username\n\n"
"@usern@name\n\n"
"hey@username")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")