import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[[:space:]])e'([[:space:]]|$|[.|,|;])";
final String string = "Nei casi suddetti, ai sensi della direttiva sul marchio europeo 'E', l'imballaggio potrà essere contrassegnato da un marchio caratterizzato da una 'E'.\n"
+ "E' così che abbiamo cominciato. Quello che e',\n"
+ "E' un giocattolo vecchio di un secolo e'' e';\n"
+ "E' ciò che chiamiamo anonimato.\n"
+ "Questo é Portland. E' un vero insediamento... e'.\n"
+ "E' venuto fuori che... questo è uno squalo delle Galapagos.\n"
+ "E' la storia di mio fratello.\n"
+ "E' un sussidio della natura.\n"
+ "Una delle cose più belle che conosco è la 'e'.\n"
+ "E' un posto per femmine anni '80 e '90.\n"
+ "E' un'altra sequenza del cervello di Motts.\n"
+ "Guardate questo cosa fa. E' una semplice argomentazione di economia comportamentale.\n"
+ "'Sai, ti sentirai meglio' e 'non preoccuparti, 'va tutto bene'.\n"
+ "Questa e' una citazione dall'articolo. Disse: \"Quello che manca davvero\" e' un signore inglese per bene, quindi disse: \"Quello che manca davvero e' una chiara struttura di idee con la quale interpretare questi diversi approcci\"\n"
+ "Tra gli anni '80 e' quattro.\n";
final String subst = "\\1è\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}