#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(en\|[^|]*|(?<!^)\G[^|]*)\|(?!2016)"
Local $sString = "column1|column2|column3|column4|column5|column6|en|col|u|lm|n8|2016|column10|column11|2016|"
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)