import Foundation
let pattern = #"(en\|[^|]*|(?<!^)\G[^|]*)\|(?!2016)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"column1|column2|column3|column4|column5|column6|en|col|u|lm|n8|2016|column10|column11|2016|"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)