$re = '/(en\|[^|]*|(?<!^)\G[^|]*)\|(?!2016)/';
$str = 'column1|column2|column3|column4|column5|column6|en|col|u|lm|n8|2016|column10|column11|2016|';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;